Out-of-bounds Write Affecting libmagic1 package, versions <5.32-7.8.1


Severity

Recommended
0.0
critical
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.85% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-LIBMAGIC1-2712705
  • published14 Apr 2022
  • disclosed18 May 2020

Introduced: 18 May 2020

CVE-2019-18218  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 libmagic1 to version 5.32-7.8.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libmagic1 package and not the libmagic1 package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

cdf_read_property_info in cdf.c in file through 5.37 does not restrict the number of CDF_VECTOR elements, which allows a heap-based buffer overflow (4-byte out-of-bounds write).

References

CVSS Base Scores

version 3.1