Information Exposure Affecting libobjc4 package, versions <10.2.1+git583-1.3.4


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.51% (43rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-LIBOBJC4-2699985
  • published14 Apr 2022
  • disclosed4 Dec 2020

Introduced: 4 Dec 2020

CVE-2020-13844  (opens in a new tab)
CWE-203  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 libobjc4 to version 10.2.1+git583-1.3.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libobjc4 package and not the libobjc4 package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

Arm Armv8-A core implementations utilizing speculative execution past unconditional changes in control flow may allow unauthorized disclosure of information to an attacker with local user access via a side-channel analysis, aka "straight-line speculation."

CVSS Base Scores

version 3.1