Out-of-bounds Read Affecting libonig4 package, versions <6.7.0-150000.3.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.97% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-LIBONIG4-3030109
  • published22 Sept 2022
  • disclosed21 Sept 2022

Introduced: 21 Sep 2022

CVE-2019-19246  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 libonig4 to version 6.7.0-150000.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libonig4 package and not the libonig4 package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

Oniguruma through 6.9.3, as used in PHP 7.3.x and other products, has a heap-based buffer over-read in str_lower_case_match in regexec.c.

CVSS Base Scores

version 3.1