Out-of-Bounds Affecting libsybdb5 package, versions <1.1.36-3.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.78% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-LIBSYBDB5-2711336
  • published14 Apr 2022
  • disclosed8 Jul 2020

Introduced: 8 Jul 2020

CVE-2019-13508  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 libsybdb5 to version 1.1.36-3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsybdb5 package and not the libsybdb5 package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

FreeTDS through 1.1.11 has a Buffer Overflow.

CVSS Base Scores

version 3.1