Use After Free The advisory has been revoked - it doesn't affect any version of package libwebkit2gtk-4_0-37-32bit  (opens in a new tab)


Threat Intelligence

EPSS
4.99% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-LIBWEBKIT2GTK403732BIT-2712486
  • published14 Apr 2022
  • disclosed24 Apr 2020

Introduced: 24 Apr 2020

CVE-2020-10018  (opens in a new tab)
CWE-416  (opens in a new tab)

Amendment

The SLES security team deemed this advisory irrelevant for SLES:15.1.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libwebkit2gtk-4_0-37-32bit package and not the libwebkit2gtk-4_0-37-32bit package as distributed by SLES.

WebKitGTK through 2.26.4 and WPE WebKit through 2.26.4 (which are the versions right before 2.28.0) contains a memory corruption issue (use-after-free) that may lead to arbitrary code execution. This issue has been fixed in 2.28.0 with improved memory handling.