Out-of-bounds Write Affecting libzmq5 package, versions <4.2.3-3.8.1


Severity

Recommended
high

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
42.46% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-LIBZMQ5-2743772
  • published14 Apr 2022
  • disclosed8 Jul 2019

Introduced: 8 Jul 2019

CVE-2019-13132  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 libzmq5 to version 4.2.3-3.8.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libzmq5 package and not the libzmq5 package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

In ZeroMQ libzmq before 4.0.9, 4.1.x before 4.1.7, and 4.2.x before 4.3.2, a remote, unauthenticated client connecting to a libzmq application, running with a socket listening with CURVE encryption/authentication enabled, may cause a stack overflow and overwrite the stack with arbitrary data, due to a buffer overflow in the library. Users running public servers with the above configuration are highly encouraged to upgrade as soon as possible, as there are no known mitigations.

References

CVSS Base Scores

version 3.1