Out-of-bounds Read Affecting memcached-devel package, versions <1.5.6-4.5.30


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.64% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-MEMCACHEDDEVEL-2711420
  • published14 Apr 2022
  • disclosed22 May 2020

Introduced: 22 May 2020

CVE-2019-15026  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 memcached-devel to version 1.5.6-4.5.30 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream memcached-devel package and not the memcached-devel package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

memcached 1.5.16, when UNIX sockets are used, has a stack-based buffer over-read in conn_to_str in memcached.c.