Out-of-bounds Write Affecting MozillaFirefox-devel package, versions <91.8.0-150000.150.27.1


0.0
high

Snyk CVSS

    Attack Complexity High
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.13% (48th percentile)
Expand this section
NVD
8.8 high
Expand this section
SUSE
7.5 high
Expand this section
Red Hat
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES151-MOZILLAFIREFOXDEVEL-6274470
  • published 25 Feb 2024
  • disclosed 7 Apr 2022

How to fix?

Upgrade SLES:15.1 MozillaFirefox-devel to version 91.8.0-150000.150.27.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream MozillaFirefox-devel package and not the MozillaFirefox-devel package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

If a compromised content process sent an unexpected number of WebAuthN Extensions in a Register command to the parent process, an out of bounds write would have occurred leading to memory corruption and a potentially exploitable crash. This vulnerability affects Thunderbird < 91.8, Firefox < 99, and Firefox ESR < 91.8.