CVE-2020-15653 Affecting MozillaFirefox-translations-common package, versions <78.1.0-3.100.2


Severity

Recommended
high

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.4% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-MOZILLAFIREFOXTRANSLATIONSCOMMON-2705494
  • published14 Apr 2022
  • disclosed4 Aug 2020

Introduced: 4 Aug 2020

CVE-2020-15653  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 MozillaFirefox-translations-common to version 78.1.0-3.100.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream MozillaFirefox-translations-common package and not the MozillaFirefox-translations-common package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

An iframe sandbox element with the allow-popups flag could be bypassed when using noopener links. This could have led to security issues for websites relying on sandbox configurations that allowed popups and hosted arbitrary content. This vulnerability affects Firefox ESR < 78.1, Firefox < 79, and Thunderbird < 78.1.

CVSS Base Scores

version 3.1