Origin Validation Error Affecting MozillaThunderbird package, versions <68.11.0-3.91.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.26% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-MOZILLATHUNDERBIRD-2705782
  • published14 Apr 2022
  • disclosed10 Aug 2020

Introduced: 10 Aug 2020

CVE-2020-15652  (opens in a new tab)
CWE-346  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 MozillaThunderbird to version 68.11.0-3.91.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream MozillaThunderbird package and not the MozillaThunderbird package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

By observing the stack trace for JavaScript errors in web workers, it was possible to leak the result of a cross-origin redirect. This applied only to content that can be parsed as script. This vulnerability affects Firefox < 79, Firefox ESR < 68.11, Firefox ESR < 78.1, Thunderbird < 68.11, and Thunderbird < 78.1.

CVSS Base Scores

version 3.1