Out-of-Bounds Affecting nasm package, versions <2.14.02-3.4.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.05% (64th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-NASM-2709237
  • published14 Apr 2022
  • disclosed6 Jul 2020

Introduced: 6 Jul 2020

CVE-2018-1000667  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 nasm to version 2.14.02-3.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nasm package and not the nasm package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

NASM nasm-2.13.03 nasm- 2.14rc15 version 2.14rc15 and earlier contains a memory corruption (crashed) of nasm when handling a crafted file due to function assemble_file(inname, depend_ptr) at asm/nasm.c:482. vulnerability in function assemble_file(inname, depend_ptr) at asm/nasm.c:482. that can result in aborting/crash nasm program. This attack appear to be exploitable via a specially crafted asm file..