Out-of-bounds Read Affecting nasm package, versions <2.14.02-3.4.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.37% (32nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-NASM-2709356
  • published14 Apr 2022
  • disclosed6 Jul 2020

Introduced: 6 Jul 2020

CVE-2018-8883  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 nasm to version 2.14.02-3.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nasm package and not the nasm package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

Netwide Assembler (NASM) 2.13.02rc2 has a buffer over-read in the parse_line function in asm/parser.c via uncontrolled access to nasm_reg_flags.