SQL Injection Affecting pdsh-dshgroup package, versions <2.33-7.6.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.88% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-PDSHDSHGROUP-2715743
  • published14 Apr 2022
  • disclosed24 Feb 2020

Introduced: 24 Feb 2020

CVE-2018-7033  (opens in a new tab)
CWE-89  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 pdsh-dshgroup to version 2.33-7.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pdsh-dshgroup package and not the pdsh-dshgroup package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

SchedMD Slurm before 17.02.10 and 17.11.x before 17.11.5 allows SQL Injection attacks against SlurmDBD.