Improper Privilege Management Affecting pdsh-machines package, versions <2.33-7.6.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.3% (67th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-PDSHMACHINES-2716009
  • published14 Apr 2022
  • disclosed24 Feb 2020

Introduced: 24 Feb 2020

CVE-2019-19728  (opens in a new tab)
CWE-269  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 pdsh-machines to version 2.33-7.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pdsh-machines package and not the pdsh-machines package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

SchedMD Slurm before 18.08.9 and 19.x before 19.05.5 executes srun --uid with incorrect privileges.

CVSS Base Scores

version 3.1