SQL Injection Affecting pdsh-netgroup package, versions <2.33-7.6.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.79% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-PDSHNETGROUP-2715784
  • published14 Apr 2022
  • disclosed24 Feb 2020

Introduced: 24 Feb 2020

CVE-2019-12838  (opens in a new tab)
CWE-89  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 pdsh-netgroup to version 2.33-7.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pdsh-netgroup package and not the pdsh-netgroup package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

SchedMD Slurm 17.11.x, 18.08.0 through 18.08.7, and 19.05.0 allows SQL Injection.

CVSS Base Scores

version 3.1