Resource Exhaustion Affecting perl-Mail-SpamAssassin package, versions <3.4.5-12.10.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
7.23% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-PERLMAILSPAMASSASSIN-2682623
  • published14 Apr 2022
  • disclosed13 Apr 2021

Introduced: 13 Apr 2021

CVE-2019-12420  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 perl-Mail-SpamAssassin to version 3.4.5-12.10.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream perl-Mail-SpamAssassin package and not the perl-Mail-SpamAssassin package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

In Apache SpamAssassin before 3.4.3, a message can be crafted in a way to use excessive resources. Upgrading to SA 3.4.3 as soon as possible is the recommended fix but details will not be shared publicly.

References

CVSS Base Scores

version 3.1