Insufficiently Protected Credentials Affecting podman-cni-config package, versions <1.4.4-4.11.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.59% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-PODMANCNICONFIG-2736336
  • published14 Apr 2022
  • disclosed10 Sept 2019

Introduced: 10 Sep 2019

CVE-2019-10214  (opens in a new tab)
CWE-522  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 podman-cni-config to version 1.4.4-4.11.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream podman-cni-config package and not the podman-cni-config package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

The containers/image library used by the container tools Podman, Buildah, and Skopeo in Red Hat Enterprise Linux version 8 and CRI-O in OpenShift Container Platform, does not enforce TLS connections to the container registry authorization service. An attacker could use this vulnerability to launch a MiTM attack and steal login credentials or bearer tokens.

CVSS Base Scores

version 3.1