Out-of-bounds Write Affecting podman-cni-config package, versions <1.4.4-4.8.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.61% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-PODMANCNICONFIG-2739771
  • published14 Apr 2022
  • disclosed27 Aug 2019

Introduced: 27 Aug 2019

CVE-2019-6778  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 podman-cni-config to version 1.4.4-4.8.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream podman-cni-config package and not the podman-cni-config package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

In QEMU 3.0.0, tcp_emu in slirp/tcp_subr.c has a heap-based buffer overflow.

References