Out-of-bounds Write Affecting postgresql12-plpython package, versions <12.2-3.5.2


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.64% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-POSTGRESQL12PLPYTHON-6358760
  • published3 Mar 2024
  • disclosed14 May 2020

Introduced: 14 May 2020

CVE-2019-10164  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 postgresql12-plpython to version 12.2-3.5.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream postgresql12-plpython package and not the postgresql12-plpython package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

PostgreSQL versions 10.x before 10.9 and versions 11.x before 11.4 are vulnerable to a stack-based buffer overflow. Any authenticated user can overflow a stack-based buffer by changing the user's own password to a purpose-crafted value. This often suffices to execute arbitrary code as the PostgreSQL operating system account.

CVSS Base Scores

version 3.1