Buffer Overflow Affecting ppp package, versions <2.4.7-5.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
19.93% (98th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-PPP-2714943
  • published14 Apr 2022
  • disclosed26 Feb 2020

Introduced: 26 Feb 2020

CVE-2020-8597  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 ppp to version 2.4.7-5.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ppp package and not the ppp package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

eap.c in pppd in ppp 2.4.2 through 2.4.8 has an rhostname buffer overflow in the eap_request and eap_response functions.

References

CVSS Base Scores

version 3.1