Directory Traversal The advisory has been revoked - it doesn't affect any version of package ruby2.5-doc-ri  (opens in a new tab)


Threat Intelligence

EPSS
2.78% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-RUBY25DOCRI-2745482
  • published14 Apr 2022
  • disclosed10 Jul 2019

Introduced: 10 Jul 2019

CVE-2018-1000079  (opens in a new tab)
CWE-22  (opens in a new tab)

Amendment

The SLES security team deemed this advisory irrelevant for SLES:15.1.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.5-doc-ri package and not the ruby2.5-doc-ri package as distributed by SLES.

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in gem installation that can result in the gem could write to arbitrary filesystem locations during installation. This attack appear to be exploitable via the victim must install a malicious gem. This vulnerability appears to have been fixed in 2.7.6.