Inefficient Regular Expression Complexity Affecting ruby2.5-rubygem-nokogiri package, versions <1.8.5-150000.3.9.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.52% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-RUBY25RUBYGEMNOKOGIRI-3123134
  • published17 Nov 2022
  • disclosed16 Nov 2022

Introduced: 16 Nov 2022

CVE-2022-24836  (opens in a new tab)
CWE-1333  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 ruby2.5-rubygem-nokogiri to version 1.8.5-150000.3.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.5-rubygem-nokogiri package and not the ruby2.5-rubygem-nokogiri package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

Nokogiri is an open source XML and HTML library for Ruby. Nokogiri &lt; v1.13.4 contains an inefficient regular expression that is susceptible to excessive backtracking when attempting to detect encoding in HTML documents. Users are advised to upgrade to Nokogiri &gt;= 1.13.4. There are no known workarounds for this issue.

CVSS Base Scores

version 3.1