Incorrect Default Permissions Affecting slurm_22_05-munge package, versions <22.05.5-150100.3.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.21% (12th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-SLURM2205MUNGE-6357712
  • published3 Mar 2024
  • disclosed30 Nov 2022

Introduced: 30 Nov 2022

CVE-2022-31251  (opens in a new tab)
CWE-276  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 slurm_22_05-munge to version 22.05.5-150100.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm_22_05-munge package and not the slurm_22_05-munge package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

A Incorrect Default Permissions vulnerability in the packaging of the slurm testsuite of openSUSE Factory allows local attackers with control over the slurm user to escalate to root. This issue affects: openSUSE Factory slurm versions prior to 22.05.2-3.3.

CVSS Base Scores

version 3.1