Race Condition Affecting slurm-devel package, versions <18.08.9-3.16.4


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.83% (55th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-SLURMDEVEL-2694854
  • published14 Apr 2022
  • disclosed24 Nov 2020

Introduced: 24 Nov 2020

CVE-2020-27746  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 slurm-devel to version 18.08.9-3.16.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-devel package and not the slurm-devel package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

Slurm before 19.05.8 and 20.x before 20.02.6 exposes Sensitive Information to an Unauthorized Actor because xauth for X11 magic cookies is affected by a race condition in a read operation on the /proc filesystem.

CVSS Base Scores

version 3.1