Race Condition Affecting slurm-slurmdbd package, versions <18.08.9-150100.3.25.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.19% (9th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-SLURMSLURMDBD-6009034
  • published19 Oct 2023
  • disclosed18 Oct 2023

Introduced: 18 Oct 2023

CVE-2023-41914  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 slurm-slurmdbd to version 18.08.9-150100.3.25.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-slurmdbd package and not the slurm-slurmdbd package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

SchedMD Slurm 23.02.x before 23.02.6 and 22.05.x before 22.05.10 allows filesystem race conditions for gaining ownership of a file, overwriting a file, or deleting files.

CVSS Base Scores

version 3.1