Out-of-bounds Write Affecting strongswan-libs0 package, versions <5.6.0-4.3.2


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.92% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-STRONGSWANLIBS0-2724100
  • published14 Apr 2022
  • disclosed25 Nov 2019

Introduced: 25 Nov 2019

CVE-2018-5388  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 strongswan-libs0 to version 5.6.0-4.3.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream strongswan-libs0 package and not the strongswan-libs0 package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

In stroke_socket.c in strongSwan before 5.6.3, a missing packet length check could allow a buffer underflow, which may lead to resource exhaustion and denial of service while reading from the socket.