Improper Verification of Cryptographic Signature Affecting typelib-1_0-Fwupd-2_0 package, versions <1.0.9-6.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.49% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-TYPELIB10FWUPD20-2709246
  • published14 Apr 2022
  • disclosed19 Jun 2020

Introduced: 19 Jun 2020

CVE-2020-10759  (opens in a new tab)
CWE-347  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 typelib-1_0-Fwupd-2_0 to version 1.0.9-6.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream typelib-1_0-Fwupd-2_0 package and not the typelib-1_0-Fwupd-2_0 package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

A PGP signature bypass flaw was found in fwupd (all versions), which could lead to the installation of unsigned firmware. As per upstream, a signature bypass is theoretically possible, but not practical because the Linux Vendor Firmware Service (LVFS) is either not implemented or enabled in versions of fwupd shipped with Red Hat Enterprise Linux 7 and 8. The highest threat from this vulnerability is to confidentiality and integrity.

CVSS Base Scores

version 3.1