Insufficiently Protected Credentials Affecting freeradius-server-mysql package, versions <3.0.21-150200.3.12.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.87% (56th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-FREERADIUSSERVERMYSQL-3184169
  • published28 Dec 2022
  • disclosed27 Dec 2022

Introduced: 27 Dec 2022

CVE-2022-41859  (opens in a new tab)
CWE-522  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 freeradius-server-mysql to version 3.0.21-150200.3.12.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream freeradius-server-mysql package and not the freeradius-server-mysql package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

In freeradius, the EAP-PWD function compute_password_element() leaks information about the password which allows an attacker to substantially reduce the size of an offline dictionary attack.

CVSS Base Scores

version 3.1