Stack-based Buffer Overflow Affecting grub2-powerpc-ieee1275 package, versions <2.04-9.34.1


0.0
high

Snyk CVSS

    Attack Complexity High
    Privileges Required High
    Scope Changed
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
6.7 medium
Expand this section
SUSE
7.5 high
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES152-GRUB2POWERPCIEEE1275-2685841
  • published 14 Apr 2022
  • disclosed 2 Mar 2021

How to fix?

Upgrade SLES:15.2 grub2-powerpc-ieee1275 to version 2.04-9.34.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream grub2-powerpc-ieee1275 package and not the grub2-powerpc-ieee1275 package as distributed by SLES:15.2. See How to fix? for SLES:15.2 relevant fixed versions and status.

A flaw was found in grub2 in versions prior to 2.06. Variable names present are expanded in the supplied command line into their corresponding variable contents, using a 1kB stack buffer for temporary storage, without sufficient bounds checking. If the function is called with a command line that references a variable with a sufficiently large payload, it is possible to overflow the stack buffer, corrupt the stack frame and control execution which could also circumvent Secure Boot protections. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.