Improper Locking Affecting gssproxy package, versions <0.8.2-3.6.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.77% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-GSSPROXY-2683121
  • published14 Apr 2022
  • disclosed6 Apr 2021

Introduced: 6 Apr 2021

CVE-2020-12658  (opens in a new tab)
CWE-667  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 gssproxy to version 0.8.2-3.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gssproxy package and not the gssproxy package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

gssproxy (aka gss-proxy) before 0.8.3 does not unlock cond_mutex before pthread exit in gp_worker_main() in gp_workers.c. NOTE: An upstream comment states "We are already on a shutdown path when running the code in question, so a DoS there doesn't make any sense, and there has been no additional information provided us (as upstream) to indicate why this would be a problem.

CVSS Base Scores

version 3.1