Integer Overflow or Wraparound Affecting ImageMagick package, versions <7.0.7.34-10.9.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.15% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-IMAGEMAGICK-2692256
  • published14 Apr 2022
  • disclosed15 Jan 2021

Introduced: 15 Jan 2021

CVE-2020-27770  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 ImageMagick to version 7.0.7.34-10.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ImageMagick package and not the ImageMagick package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

Due to a missing check for 0 value of replace_extent, it is possible for offset p to overflow in SubstituteString(), causing potential impact to application availability. This could be triggered by a crafted input file that is processed by ImageMagick. This flaw affects ImageMagick versions prior to 7.0.8-68.

CVSS Base Scores

version 3.1