Improper Input Validation Affecting libcryptopp5_6_5 package, versions <5.6.5-1.6.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
4.2% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-LIBCRYPTOPP565-2661747
  • published14 Apr 2022
  • disclosed6 Oct 2021

Introduced: 6 Oct 2021

CVE-2016-9939  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 libcryptopp5_6_5 to version 5.6.5-1.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcryptopp5_6_5 package and not the libcryptopp5_6_5 package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

Crypto++ (aka cryptopp and libcrypto++) 5.6.4 contained a bug in its ASN.1 BER decoding routine. The library will allocate a memory block based on the length field of the ASN.1 object. If there is not enough content octets in the ASN.1 object, then the function will fail and the memory block will be zeroed even if its unused. There is a noticeable delay during the wipe for a large allocation.