Resource Exhaustion Affecting libexif-devel package, versions <0.6.22-5.6.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.8% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-LIBEXIFDEVEL-2710257
  • published14 Apr 2022
  • disclosed8 Jul 2020

Introduced: 8 Jul 2020

CVE-2018-20030  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 libexif-devel to version 0.6.22-5.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libexif-devel package and not the libexif-devel package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

An error when processing the EXIF_IFD_INTEROPERABILITY and EXIF_IFD_EXIF tags within libexif version 0.6.21 can be exploited to exhaust available CPU resources.