Use After Free Affecting libhdf5hl_fortran_1_10_8-gnu-openmpi2-hpc package, versions <1.10.8-150200.8.7.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.25% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-LIBHDF5HLFORTRAN1108GNUOPENMPI2HPC-3097525
  • published2 Nov 2022
  • disclosed1 Nov 2022

Introduced: 1 Nov 2022

CVE-2021-46242  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 libhdf5hl_fortran_1_10_8-gnu-openmpi2-hpc to version 1.10.8-150200.8.7.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libhdf5hl_fortran_1_10_8-gnu-openmpi2-hpc package and not the libhdf5hl_fortran_1_10_8-gnu-openmpi2-hpc package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

HDF5 v1.13.1-1 was discovered to contain a heap-use-after free via the component H5AC_unpin_entry.

CVSS Base Scores

version 3.1