Out-of-bounds Write Affecting libjpeg62-devel package, versions <62.2.0-5.18.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.73% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-LIBJPEG62DEVEL-2675093
  • published14 Apr 2022
  • disclosed11 Jun 2021

Introduced: 11 Jun 2021

CVE-2020-17541  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 libjpeg62-devel to version 62.2.0-5.18.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libjpeg62-devel package and not the libjpeg62-devel package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

Libjpeg-turbo all version have a stack-based buffer overflow in the "transform" component. A remote attacker can send a malformed jpeg file to the service and cause arbitrary code execution or denial of service of the target service.

CVSS Base Scores

version 3.1