Buffer Overflow Affecting liblouis-data package, versions <3.11.0-150200.3.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.45% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-LIBLOUISDATA-2935282
  • published25 Jun 2022
  • disclosed24 Jun 2022

Introduced: 24 Jun 2022

CVE-2022-26981  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 liblouis-data to version 3.11.0-150200.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblouis-data package and not the liblouis-data package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

Liblouis through 3.21.0 has a buffer overflow in compilePassOpcode in compileTranslationTable.c (called, indirectly, by tools/lou_checktable.c).

CVSS Base Scores

version 3.1