Buffer Overflow Affecting liblouis-devel package, versions <3.11.0-150200.3.13.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.36% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-LIBLOUISDEVEL-5497391
  • published5 May 2023
  • disclosed13 Apr 2023

Introduced: 13 Apr 2023

CVE-2023-26768  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 liblouis-devel to version 3.11.0-150200.3.13.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblouis-devel package and not the liblouis-devel package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

Buffer Overflow vulnerability found in Liblouis v.3.24.0 allows a remote attacker to cause a denial of service via the compileTranslationTable.c and lou_setDataPath functions.

CVSS Base Scores

version 3.1