Integer Overflow or Wraparound Affecting libMagickCore-7_Q16HDRI6 package, versions <7.0.7.34-10.9.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.16% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-LIBMAGICKCORE7Q16HDRI6-2691821
  • published14 Apr 2022
  • disclosed15 Jan 2021

Introduced: 15 Jan 2021

CVE-2020-27764  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 libMagickCore-7_Q16HDRI6 to version 7.0.7.34-10.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libMagickCore-7_Q16HDRI6 package and not the libMagickCore-7_Q16HDRI6 package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

In /MagickCore/statistic.c, there are several areas in ApplyEvaluateOperator() where a size_t cast should have been a ssize_t cast, which causes out-of-range values under some circumstances when a crafted input file is processed by ImageMagick. Red Hat Product Security marked this as Low severity because although it could potentially lead to an impact to application availability, no specific impact was shown in this case. This flaw affects ImageMagick versions prior to 6.9.10-69.

CVSS Base Scores

version 3.1