Out-of-bounds Write Affecting libqpdf26 package, versions <9.0.2-150200.3.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.27% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-LIBQPDF26-3021726
  • published13 Sept 2022
  • disclosed12 Sept 2022

Introduced: 12 Sep 2022

CVE-2021-36978  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 libqpdf26 to version 9.0.2-150200.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libqpdf26 package and not the libqpdf26 package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

QPDF 9.x through 9.1.1 and 10.x through 10.0.4 has a heap-based buffer overflow in Pl_ASCII85Decoder::write (called from Pl_AES_PDF::flush and Pl_AES_PDF::finish) when a certain downstream write fails.

CVSS Base Scores

version 3.1