Out-of-bounds Write Affecting librsvg-2-2 package, versions <2.46.5-3.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.72% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-LIBRSVG22-2682763
  • published14 Apr 2022
  • disclosed28 Apr 2021

Introduced: 28 Apr 2021

CVE-2021-25900  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 librsvg-2-2 to version 2.46.5-3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream librsvg-2-2 package and not the librsvg-2-2 package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

An issue was discovered in the smallvec crate before 0.6.14 and 1.x before 1.6.1 for Rust. There is a heap-based buffer overflow in SmallVec::insert_many.

CVSS Base Scores

version 3.1