Out-of-bounds Write Affecting libsndfile1-32bit package, versions <1.0.28-5.12.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.57% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-LIBSNDFILE132BIT-2667643
  • published14 Apr 2022
  • disclosed17 Aug 2021

Introduced: 17 Aug 2021

CVE-2018-13139  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 libsndfile1-32bit to version 1.0.28-5.12.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsndfile1-32bit package and not the libsndfile1-32bit package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

A stack-based buffer overflow in psf_memset in common.c in libsndfile 1.0.28 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted audio file. The vulnerability can be triggered by the executable sndfile-deinterleave.

CVSS Base Scores

version 3.1