Out-of-bounds Write Affecting libz1-32bit package, versions <1.2.11-150000.3.30.1


0.0
high

Snyk CVSS

    Attack Complexity High
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.28% (69th percentile)
Expand this section
NVD
7.5 high
Expand this section
SUSE
8.1 high
Expand this section
Red Hat
8.2 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES152-LIBZ132BIT-2637378
  • published 14 Apr 2022
  • disclosed 30 Mar 2022

How to fix?

Upgrade SLES:15.2 libz1-32bit to version 1.2.11-150000.3.30.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libz1-32bit package and not the libz1-32bit package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

zlib before 1.2.12 allows memory corruption when deflating (i.e., when compressing) if the input has many distant matches.

References