Out-of-bounds Write Affecting libz1-32bit package, versions <1.2.11-150000.3.33.1


0.0
high

Snyk CVSS

    Attack Complexity High
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.34% (72nd percentile)
Expand this section
NVD
9.8 critical
Expand this section
SUSE
8.1 high
Expand this section
Red Hat
7 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES152-LIBZ132BIT-3012964
  • published 1 Sep 2022
  • disclosed 31 Aug 2022

How to fix?

Upgrade SLES:15.2 libz1-32bit to version 1.2.11-150000.3.33.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libz1-32bit package and not the libz1-32bit package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

zlib through 1.2.12 has a heap-based buffer over-read or buffer overflow in inflate in inflate.c via a large gzip header extra field. NOTE: only applications that call inflateGetHeader are affected. Some common applications bundle the affected zlib source code but may be unable to call inflateGetHeader (e.g., see the nodejs/node reference).

References