CVE-2022-40957 Affecting MozillaFirefox package, versions <102.3.0-150200.152.61.1


Severity

Recommended
high

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.24% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-MOZILLAFIREFOX-3037080
  • published30 Sept 2022
  • disclosed26 Sept 2022

Introduced: 26 Sep 2022

CVE-2022-40957  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 MozillaFirefox to version 102.3.0-150200.152.61.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream MozillaFirefox package and not the MozillaFirefox package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

Inconsistent data in instruction and data cache when creating wasm code could lead to a potentially exploitable crash.<br>This bug only affects Firefox on ARM64 platforms.. This vulnerability affects Firefox ESR < 102.3, Thunderbird < 102.3, and Firefox < 105.

CVSS Base Scores

version 3.1