Origin Validation Error Affecting MozillaFirefox-translations-common package, versions <78.1.0-8.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.26% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-MOZILLAFIREFOXTRANSLATIONSCOMMON-2706209
  • published14 Apr 2022
  • disclosed6 Aug 2020

Introduced: 6 Aug 2020

CVE-2020-15652  (opens in a new tab)
CWE-346  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 MozillaFirefox-translations-common to version 78.1.0-8.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream MozillaFirefox-translations-common package and not the MozillaFirefox-translations-common package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

By observing the stack trace for JavaScript errors in web workers, it was possible to leak the result of a cross-origin redirect. This applied only to content that can be parsed as script. This vulnerability affects Firefox < 79, Firefox ESR < 68.11, Firefox ESR < 78.1, Thunderbird < 68.11, and Thunderbird < 78.1.

CVSS Base Scores

version 3.1