Out-of-bounds Read Affecting oniguruma-devel package, versions <6.7.0-150000.3.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
6.89% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-ONIGURUMADEVEL-3030108
  • published22 Sept 2022
  • disclosed21 Sept 2022

Introduced: 21 Sep 2022

CVE-2019-19204  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 oniguruma-devel to version 6.7.0-150000.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream oniguruma-devel package and not the oniguruma-devel package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

An issue was discovered in Oniguruma 6.x before 6.9.4_rc2. In the function fetch_interval_quantifier (formerly known as fetch_range_quantifier) in regparse.c, PFETCH is called without checking PEND. This leads to a heap-based buffer over-read.

CVSS Base Scores

version 3.1