Buffer Overflow Affecting openconnect package, versions <7.08-6.9.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
4.74% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-OPENCONNECT-2707451
  • published14 Apr 2022
  • disclosed15 Jul 2020

Introduced: 15 Jul 2020

CVE-2020-12823  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 openconnect to version 7.08-6.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openconnect package and not the openconnect package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

OpenConnect 8.09 has a buffer overflow, causing a denial of service (application crash) or possibly unspecified other impact, via crafted certificate data to get_cert_name in gnutls.c.

CVSS Base Scores

version 3.1