OS Command Injection Affecting openssl-1_1 package, versions <1.1.1d-150200.11.48.1


0.0
medium

Snyk CVSS

    Attack Complexity Low
    Privileges Required High
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 8.51% (95th percentile)
Expand this section
NVD
9.8 critical
Expand this section
SUSE
6.7 medium
Expand this section
Red Hat
6.7 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES152-OPENSSL11-2941146
  • published 5 Jul 2022
  • disclosed 4 Jul 2022

How to fix?

Upgrade SLES:15.2 openssl-1_1 to version 1.1.1d-150200.11.48.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openssl-1_1 package and not the openssl-1_1 package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

In addition to the c_rehash shell command injection identified in CVE-2022-1292, further circumstances where the c_rehash script does not properly sanitise shell metacharacters to prevent command injection were found by code review. When the CVE-2022-1292 was fixed it was not discovered that there are other places in the script where the file names of certificates being hashed were possibly passed to a command executed through the shell. This script is distributed by some operating systems in a manner where it is automatically executed. On such operating systems, an attacker could execute arbitrary commands with the privileges of the script. Use of the c_rehash script is considered obsolete and should be replaced by the OpenSSL rehash command line tool. Fixed in OpenSSL 3.0.4 (Affected 3.0.0,3.0.1,3.0.2,3.0.3). Fixed in OpenSSL 1.1.1p (Affected 1.1.1-1.1.1o). Fixed in OpenSSL 1.0.2zf (Affected 1.0.2-1.0.2ze).

References