Improper Certificate Validation Affecting openssl-1_1 package, versions <1.1.1d-150200.11.62.1


medium

Snyk CVSS

    Attack Complexity High
    Privileges Required High
    User Interaction Required

    Threat Intelligence

    EPSS 0.13% (48th percentile)
Expand this section
NVD
5.3 medium
Expand this section
SUSE
2 low
Expand this section
Red Hat
5.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES152-OPENSSL11-5416269
  • published 7 Apr 2023
  • disclosed 6 Apr 2023

How to fix?

Upgrade SLES:15.2 openssl-1_1 to version 1.1.1d-150200.11.62.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openssl-1_1 package and not the openssl-1_1 package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

The function X509_VERIFY_PARAM_add0_policy() is documented to implicitly enable the certificate policy check when doing certificate verification. However the implementation of the function does not enable the check which allows certificates with invalid or incorrect policies to pass the certificate verification.

As suddenly enabling the policy check could break existing deployments it was decided to keep the existing behavior of the X509_VERIFY_PARAM_add0_policy() function.

Instead the applications that require OpenSSL to perform certificate policy check need to use X509_VERIFY_PARAM_set1_policies() or explicitly enable the policy check by calling X509_VERIFY_PARAM_set_flags() with the X509_V_FLAG_POLICY_CHECK flag argument.

Certificate policy checks are disabled by default in OpenSSL and are not commonly used by applications.