SQL Injection Affecting postgresql12-pltcl package, versions <12.4-8.6.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.23% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES152-POSTGRESQL12PLTCL-2704197
  • published14 Apr 2022
  • disclosed18 Aug 2020

Introduced: 18 Aug 2020

CVE-2020-14349  (opens in a new tab)
CWE-89  (opens in a new tab)
CWE-427  (opens in a new tab)

How to fix?

Upgrade SLES:15.2 postgresql12-pltcl to version 12.4-8.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream postgresql12-pltcl package and not the postgresql12-pltcl package as distributed by SLES. See How to fix? for SLES:15.2 relevant fixed versions and status.

It was found that PostgreSQL versions before 12.4, before 11.9 and before 10.14 did not properly sanitize the search_path during logical replication. An authenticated attacker could use this flaw in an attack similar to CVE-2018-1058, in order to execute arbitrary SQL command in the context of the user used for replication.

CVSS Base Scores

version 3.1